Sketch of the required+ Foundation 1.1.0 Roadmap
We discontinue development of the required+ Foundation theme – here is why.×

Now that we survived another apocalypse and are about to celebrate the holiday season with our closest ones, let’s talk a little bit about the future of required+ Foundation and our plans for version 1.1.0, supposed to power your site February 2013.

Overview

Here is a brief overview on what we plan to add in version 1.1.0 coming in February 2013:

required+ Foundation

  • SCSS version with wp-sass
  • Complete German translation

required+ Starter

  • SCSS version with wp-sass
  • Complete German translation

This Website

The Plugins

  • Improve support for WordPress 3.5

required+ Foundation & Starter – the themes

We’ve been told that Foundation 4 might be ready in January 2013 – this would be awesome and of course we will try to integrate it asap, but there is more stuff planned for version 1.1.0 – for both the parent and starter child theme.

SCSS integration

As you might know already Foundation uses SCSS internally and you can download a SCSS version as a Compass Gem. We are currently working on a smooth integration of SCSS in required+ Foundation to give you more power and make you faster in styling your theme with SCSS. The solution we are implementing is based on the awesome wp-sass by Robert O’Rourke.

German translation

As we are from the German speaking part of Switzerland and some of us from Germany, most of our sites need to have a German translation of the theme. For version 1.1.0 required+ Foundation and required+ Starter offers a complete German translation. So in the future, if your site is in German you simply add the following line to your wp-config.php file and all the text strings in the theme will be translated:

define('WPLANG', 'de_DE');

required+ Themes – this website

As we plan to release more tutorials regarding WordPress and the required+ Themes every two weeks next year, we will start to link the appropriate ones to the matching pages in the docs through WordPress built-in tags for your convenience.

required+ Foundation Plugins

WordPress 3.5 is still fresh and one of the highlights, the new Media Manager has a new feature to create galleries and we will update our media related plugins to support this in version 1.1.0.

Well that’s it for the moment, have a save holiday season with your loved ones!


Getting started with required+ Foundation

The required+ Foundation parent theme is a powerful responsive WordPress theme that gets you started in no time. Read the docs, download the theme and create something awesome.

Download required+ Foundation »


16 thoughts on “Roadmap to required+ Foundation 1.1.0

  1. First of all, thanks for required+. It’s just what I was looking for. I’m looking forward to the next release which incorporates scss. I am about to start to crate a new WordPress site using required+. I prefer to use scss but will probably start the process with this version. Will I be able to update required+ easilñy once version 1.1.0 is released?

    Thanks again!

    • Thanks for your feedback Nathan. We plan to make the update of the parent theme 1.1.0 very easy and if there are changes needed to make SCSS work with your child theme, we will gladly offer an update guide on the site here.

  2. Thank you very much for your work. I hope to start a fresh project with required+ soon.

    How can we manage the theme’s translation? I see the .pot files but they seem to be empty, or am I seeing it wrong?

    • You are very welcome Alvaro, the .pot file is empty and ready to create your own translation. We usually use the fantastic Codestyling Localization plugin to create the translations from the empty .pot file. Of course you could use something like PoEdit to create the translations, but the plugin works like a charm. Let me know if that answers your question.

  3. Zurb have recently announced foundation 4 to be released in mid feb this year, perhaps it’s worth holding off and releasing with foundation 4 built in rather than 3.4? Either way, looking forward to the new release.

  4. Btw, I have got some problem with the interface design when I tried to access the theme in the Mozilla Firefox and Google Chrome for desktop.
    1. As you can see at this url http://www.flickr.com/photos/92780513@N08/8426582211/in/photostream. There are 2 words that overlap.
    2. At url http://www.flickr.com/photos/92780513@N08/8427698631/in/photostream, show us, there are too narrow space to could be show the dropdown menu. I should put my mouse pointer over the space around the arrow sign to show the dropdown menu.

    Do you have any idea to solve these problems? Thank you.

    • That is strange agi, could you send us the link so we can have a look at the actual site? From the pictures I would say there is something wrong with the padding and/or margin of these elements, have you tried checking it with Firebug in Firefox or something similar?

    • Yes we are Ben, we simply don’t have a lot time at the moment. We are working on the docs for the next release, but you can checkout the RC versions and update Foundation within the child theme yourself using the the docs provided by ZURB.

Leave a Reply

You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>